Alternate Way for Configuring EIGRP on NX-OS

Author
Carole Warner Reece
Architect

Most Cisco documents state that networks and interfaces are added to the EIGRP routing process in NX-OS using the interface configuration mode. The Cisco NX-OS/IOS EIGRP Comparison page states this, so do the Configuring EIGRP pages in the Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide, Release 5.x documentation. These commands work fine. However, I recently found that this is not the only way to configure EIGRP on the Nexus 7000.

One of my customers asked me to look over his EIGRP configuration. He had two IP interfaces configured on SVIs:

N7K1# sh ip int brie
IP Interface Status for VRF "default"(1)
Interface            IP Address      Interface Status
Vlan5                10.13.5.252     protocol-up/link-up/admin-up      
Vlan24               10.13.24.8      protocol-up/link-up/admin-up      
N7K1#

The VLANs were running on port-channels on a N7K-M108X2-12L (10 Gbps Ethernet XL Module) and a  N7K-M148GS-11L (1000 Mbps Optical Ethernet XL Module.)  He had three EIGRP neighbors on VLAN 24:

N7K1# sh ip eigrp nei
IP-EIGRP neighbors for process 100 VRF default
H   Address           Interface     Hold   Uptime      SRTT        RTO     Q    Seq
                                    (sec)                          (ms)   Cnt   Num
2   10.13.24.10           vlan24    10       2w3d         1        200     0    149 
1   10.13.24.11           vlan24    11       2w3d         1        200     0    120 
0   10.13.24.9            vlan24    11       2w3d         1        200     0    18  
N7K1#

Only VLAN 24 was an EIGRP interface:

N7K1# sh ip eigrp int brie
IP-EIGRP interfaces for process 100 VRF default

                         Xmit Queue  Mean   Pacing Time     Multicast    Pending
Interface       Peers   Un/Reliable  SRTT    Un/Reliable    Flow Timer   Routes
vlan24              3          0/0     1          0/1            50         0
N7K1#


I then noticed he had implemented EIGRP the ‘old fashioned’ way, and had configured network statements under the EIGRP routing process:

N7K1# sh run eigrp

!Command: show running-config eigrp
!Time: Wed Nov 23 11:00:00 2011

version 5.1(4)
feature eigrp

router eigrp 100
  network 10.0.0.0/8

interface Vlan5
  ip passive-interface eigrp 100


N7K1#

I also checked his interface configuration:

N7K1# sh run int vlan5, vlan 24

!Command: show running-config interface Vlan5, Vlan24
!Time: Fri Nov 23 11:13:38 2011

version 5.1(4)

interface Vlan5
  no ip redirects
  ip address 10.13.5.252/24
  ip passive-interface eigrp 100
  hsrp version 2
  hsrp 5
    preempt delay minimum 60
   priority 110
   timers 1 3
   ip 10.13.5.254
   no shutdown

interface Vlan24
  no ip redirects
  ip address 10.13.24.8/24
  no shutdown

N7K1#

What I learned – at least with some versions of NX-OS, you can configure EIGRP using network commands under the routing process.

In any case, I prefer using interface commands to configure EIGRP in NX-OS – I think it allows you more control. Based on the Cisco documentation, it appears to be the supported mechanism so if you have to call TAC it is probably what they expect to see.

— cwr

_________________________________________________________________________________________

More on Nexus Design and Configuration
For more information on Nexus designs, you may want to review the following articles:

Leave a Reply

 

Nick Kelly

Cybersecurity Engineer, Cisco

Nick has over 20 years of experience in Security Operations and Security Sales. He is an avid student of cybersecurity and regularly engages with the Infosec community at events like BSides, RVASec, Derbycon and more. The son of an FBI forensics director, Nick holds a B.S. in Criminal Justice and is one of Cisco’s Fire Jumper Elite members. When he’s not working, he writes cyberpunk and punches aliens on his Playstation.

 

Virgilio “BONG” dela Cruz Jr.

CCDP, CCNA V, CCNP, Cisco IPS Express Security for AM/EE
Field Solutions Architect, Tech Data

Virgilio “Bong” has sixteen years of professional experience in IT industry from academe, technical and customer support, pre-sales, post sales, project management, training and enablement. He has worked in Cisco Technical Assistance Center (TAC) as a member of the WAN and LAN Switching team. Bong now works for Tech Data as the Field Solutions Architect with a focus on Cisco Security and holds a few Cisco certifications including Fire Jumper Elite.

 

John Cavanaugh

CCIE #1066, CCDE #20070002, CCAr
Chief Technology Officer, Practice Lead Security Services, NetCraftsmen

John is our CTO and the practice lead for a talented team of consultants focused on designing and delivering scalable and secure infrastructure solutions to customers across multiple industry verticals and technologies. Previously he has held several positions including Executive Director/Chief Architect for Global Network Services at JPMorgan Chase. In that capacity, he led a team managing network architecture and services.  Prior to his role at JPMorgan Chase, John was a Distinguished Engineer at Cisco working across a number of verticals including Higher Education, Finance, Retail, Government, and Health Care.

He is an expert in working with groups to identify business needs, and align technology strategies to enable business strategies, building in agility and scalability to allow for future changes. John is experienced in the architecture and design of highly available, secure, network infrastructure and data centers, and has worked on projects worldwide. He has worked in both the business and regulatory environments for the design and deployment of complex IT infrastructures.